2014年4月11日 星期五

第一代 iPad 的「無法下載應用程式」


客人匯報無法安裝在 OTA 上的 IPA 檔,出現「無法下載應用程式」錯誤。通常是由於 Provisioning 內沒有裝置的 UDID。檢查過不是這個問題。有人指 Apple 在 Xcode 5.1 起不支援舊 iPad 的 OTA 下載,於是找來 Xcode 5.0.1 生成新的 IPA,情況不變。客人使用的是 iPad 2 iOS 7.1,IPA 需要放在 HTTPS,我連 Plist 都放到 HTTP,情況依舊...。


最後找到問題是基於 Build Settings 中支援 Arm 64。只要除去 Arm 64 相關的兩個設定,生成出來的 IPA 便能在 iPad iOS 5.1.1 上安裝。

沒有留言: